BlueTie Drive Backup & Sharing is currently unavailable due to a network outage
Incident Report for BlueTie Service Status
Resolved
Our service provider has indicated that the network issue has been resolved. We have confirmed by accessing all BlueTie Drive services.
Posted Sep 27, 2022 - 15:42 EDT
Investigating
This issue is being investigated by the service provider. We will provide an update as they are received.
Posted Sep 27, 2022 - 15:07 EDT
This incident affected: 3rd Party Solutions (BlueTie Drive File & Folder backup and sharing).