Partial outage
Incident Report for BlueTie Service Status
Resolved
All services are fully operational.
Posted Apr 06, 2024 - 09:12 EDT
Update
The issue is understood and services are slowly coming back online.
Posted Apr 06, 2024 - 08:47 EDT
Investigating
A portion of our users are experience an outage. We are investigating and will keep this page updated.
Posted Apr 06, 2024 - 07:58 EDT
This incident affected: BlueTie Proprietary Solutions (Webmail, POP-IMAP-SMTP, Outbound Email Deliverability, Inbound Email Delivery).