Office 365 service degradation

Incident Report for BlueTie Service Status

Resolved

We are no longer experiencing issues and will close this event.
Posted Jan 21, 2026 - 17:14 EST

Identified

Microsoft has identified an issue with an upstream ISP experiencing a routing issue. The latest update from Microsoft is that the issue is resolved, yet we continue to have issues during our testing of the service, so we are opening this alert until our issues subside. We have communicated the ongoing issues to Microsoft.
Posted Jan 21, 2026 - 14:35 EST
This incident affected: 3rd Party Solutions (Office365 Services).