Multiple service providers experiencing degradations / outages

Incident Report for BlueTie Service Status

Resolved

All services have returned to normal.
Posted Oct 29, 2025 - 19:10 EDT

Identified

Latest update from Microsoft: We're deploying a previous healthy configuration to the affected portions of infrastructure to resolve this issue. This is being done in tandem with efforts to rebalance traffic across healthy infrastructure to achieve recovery as quickly as possible.
Posted Oct 29, 2025 - 15:13 EDT

Investigating

Many service providers, including Microsoft, Sophos and others are experiencing outages and service degradations. This may be impacting non-BlueTie services that you purchase through us. We will keep you posted as we learn more.
Posted Oct 29, 2025 - 13:09 EDT
This incident affected: 3rd Party Solutions (Hosted Exchange (non-Office 365), Sophos Email Security, Sharesync File & Folder backup and sharing, Elevate VOIP, Office365 Services).