Webmail is currently unavailable

Incident Report for BlueTie Service Status

Resolved

This incident has been resolved.
Posted May 04, 2023 - 16:23 EDT

Update

Our DBAs successfully brought the database back online. Everything is fully functional at this time.
Posted May 04, 2023 - 13:28 EDT

Investigating

Backend DB went unavailable. We are recovering now. Will be back online shortly.
Posted May 04, 2023 - 13:17 EDT
This incident affected: BlueTie Proprietary Solutions (Webmail).