Office 365 service degradation
Incident Report for BlueTie Service Status
Resolved
Closing this. Microsoft's latest update:

From monitoring service telemetry, most users should now experience relief. We’ve completed our optimizations and we're continuing our period of extended monitoring to ensure the availability remains stable.
Posted Nov 26, 2024 - 07:56 EST
Monitoring
Latest from Microsoft:

Our monitoring indicates that a large portion of affected users and services are seeing recovery following our mitigation efforts. We're working on addressing the lingering regions that are still seeing small impact to fully restore service availability, which we still expect to complete by Monday, November 25, 2024 at 10:00 PM EST
.
Expect full recovery by 10PM EST 11/25/2024.
Posted Nov 25, 2024 - 21:22 EST
Update
Microsoft's latest update:

We identified a change in the environment that resulted in an influx in request retries routed through affected servers. Our optimizations, which enhanced the infrastructure's processing capabilities, continue to provide incremental relief. We're monitoring the service and continuing our work to perform any follow-up actions or opening additional workstreams needed to fully resolve the problem.

We understand the significant impact of this event to your organization, we're treating this issue with the highest priority, and we're working to provide relief as soon as possible.
Posted Nov 25, 2024 - 18:26 EST
Identified
Microsoft is experiencing a degradation which, to some, may be an outage of services including Exchange Email, SharePoint, OneDrive, and most online apps. This has been ongoing since 9:45PM EST on 11/24/2024. We will provide updates here as we get them from Microsoft.
Posted Nov 25, 2024 - 15:18 EST
This incident affected: 3rd Party Solutions (Office365 Services).