Service degration

Incident Report for BlueTie Service Status

Resolved

Everything is fully restored. We are monitoring.
Posted Jun 15, 2026 - 16:15 EDT

Update

We are restoring services at this time.
Posted Jun 15, 2026 - 15:25 EDT

Identified

We are experiencing an issue with a portion of our infrastructure, include a few of our mailstores. We are currently investigating and will update as soon as we learn more.
Posted Jun 15, 2026 - 14:59 EDT
This incident affected: BlueTie Proprietary Solutions (Webmail, POP-IMAP-SMTP).