Email Inaccessible
Incident Report for BlueTie Service Status
Resolved
All services are completely restored as of 12:30AM EST.
Posted Apr 14, 2022 - 04:56 UTC
Identified
Filesystems are coming back online. Services are being restored.
Posted Apr 14, 2022 - 03:58 UTC
Update
Our team is at the datacenter investigating.
Posted Apr 14, 2022 - 03:41 UTC
Investigating
We are currently investigating an issue with our storage subsystem. Presently all of our email services are down because of this.
Posted Apr 14, 2022 - 03:10 UTC
This incident affected: BlueTie Proprietary Solutions (Webmail, POP-IMAP-SMTP, Outbound Email Deliverability, Inbound Email Delivery).