Google Workspace email delivery issues
Incident Report for BlueTie Service Status
Resolved
Google reports this issue as resolved.
Posted Dec 01, 2023 - 07:41 EST
Monitoring
8:05 PM UTC
Google engineers have taken required mitigation measures.

New emails should generally not be seeing any issues. However older emails will be auto retried and should be delivered within the next couple of hours.

Our engineers continue to monitor the issue until full recovery.
Posted Nov 30, 2023 - 15:23 EST
Update
We are continuing to work on a fix for this issue.
Posted Nov 30, 2023 - 14:43 EST
Identified
Google has been experiencing issues with Google Workspace and GMail since around 11:30AM EST today. Email is either delayed or never received. Google is working to understand the issue and at this time. This is their latest status:

6:23 PM UTC
We are experiencing an issue with Gmail beginning at Thursday, 2023-11-30 08:30 US/Pacific.

Mitigation work is currently underway by our engineering team.

We do not have an ETA for mitigation at this point.
Posted Nov 30, 2023 - 14:41 EST
This incident affected: 3rd Party Solutions (Google Workspace / GMail).